View Single Post
  #6 (permalink)  
Old 10-19-2011, 06:15 PM
Rod Speed
Guest
 
Posts: n/a
Default Re: Delayed Write Failed - could I have lost data?

John John MVP wrote

> The data was in the write cache,


You dont know that the data he deliberately copied to the USB drive was in the write cache.

Its very unlikely that it still was given that he tried to safely remove the hard drive and had
the system say that it couldnt do that. That should have flushed the write cache to the drive.

Its much more likely that what got lost was what the system was attempting to write
to the USB drive at the time the system was hibernated, different data entirely.

> it wasn't flushed to the disk so it was lost when the computer was rebooted.


You dont know that that was the data that he attempted to write to the USB drive.

> These may be helpful:


> http://www.storagereview.com/guide/cacheWrite.html
> http://support.microsoft.com/kb/818788
> http://technet.microsoft.com/en-us/s...rnals/bb897438
>


> On 10/19/2011 2:13 PM, Tim Meddick wrote:
>> What the messages basically meant were that your laptop had been
>> attempting to save data to the portable drive, but that in your
>> trying to "out smart" the warning that the "drive could NOT be
>> safely removed at this time" (or similar), there was corruption of
>> that data that was being written to the drive - *at that time*.
>>
>> This data corruption was limited to the file that was being written
>> at the time the PC lost power due to the end of the hibernate
>> sequence. And also, the MFT would have lost it's validity due to the
>> fact it could not be updated after the loss.
>>
>> The MFT was fixed by running chkdsk, and the data was probably some
>> inconsequential file written by a background process that enumerates
>> removable media (e.g. Window's Media Player). But I think you got off
>> lightly, the file system could have been damaged beyond repair on the
>> portable drive, and all data on it lost permanently.
>>
>> You should always wait until Windows says that you may safely remove
>> a drive - else, if Windows will allow it, configure the device for
>> quick removal by check-marking the appropriate box in it's Device
>> Manager "Properties" for that drive.
>>
>> ==
>>
>> Cheers, Tim Meddick, Peckham, London. :-)
>>
>>
>>
>>
>> <void.no.spam.com@gmail.com> wrote in message
>> news:2f9ce058-7bf9-45ce-b7dd-5dad1b98e98d@g25g2000yqh.googlegroups.com...
>>> Last night I was copying files from a Windows XP laptop to a USB
>>> external hard drive. Then when I tried to safely remove the hard
>>> drive, I got an error saying "Generic volume cannot be stopped".
>>> I've seen this error before and it goes away if I restart Windows,
>>> but this time I didn't want to restart, so I just put my laptop into
>>> hibernation, and when I brought it out of hibernation, I was able to
>>> safely remove the drive.
>>>
>>> Then later I copied more files to the USB drive, and when I tried to
>>> safely remove it again, I got the "Generic volume cannot be stopped"
>>> error again. So I put the laptop into hibernation again, but when I
>>> brought the laptop out of hibernation, Windows displayed a dialog
>>> box saying:
>>>
>>> "Delayed Write Failed - Windows was unable to save all the data for
>>> the file e:\$Mft. The data has been lost. This error may be caused
>>> by a failure of your computer hardware or network connection. Please
>>> try to save this file elsewhere."
>>>
>>> My USB drive is drive E, and the $Mft apparently stands for master
>>> file table. That error seems to say that data was definitely lost,
>>> but when I ran a chkdsk on the drive, I got the following output:
>>>
>>> C:\Documents and Settings\Administrator>chkdsk e: /f /v /r
>>> The type of the file system is NTFS.
>>> Volume label is Elements.
>>>
>>> CHKDSK is verifying files (stage 1 of 5)...
>>> File verification completed.
>>> CHKDSK is verifying indexes (stage 2 of 5)...
>>> Index verification completed.
>>> Cleaning up minor inconsistencies on the drive.
>>> CHKDSK is verifying security descriptors (stage 3 of 5)...
>>> Cleaning up 12 unused index entries from index $SII of file 9.
>>> Cleaning up 12 unused index entries from index $SDH of file 9.
>>> Cleaning up 12 unused security descriptors.
>>> Fixing mirror copy of the security descriptors data stream.
>>> Security descriptor verification completed.
>>> CHKDSK is verifying file data (stage 4 of 5)...
>>> File data verification completed.
>>> CHKDSK is verifying free space (stage 5 of 5)...
>>> Free space verification is complete.
>>>
>>> 625131831 KB total disk space.
>>> 577839972 KB in 1884 files.
>>> 1024 KB in 437 indexes.
>>> 0 KB in bad sectors.
>>> 87383 KB in use by the system.
>>> 65536 KB occupied by the log file.
>>> 47203452 KB available on disk.
>>>
>>> 4096 bytes in each allocation unit.
>>> 156282957 total allocation units on disk.
>>> 11800863 allocation units available on disk.
>>>
>>> That chkdsk output seems to indicate the drive only had minor
>>> inconsistencies and problems with security descriptors. It doesn't
>>> say anything about data errors. Is it possible that I still lost
>>> data on the drive?




Reply With Quote
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45